Better Search Replace 플러그인 보안 취약점 패치 및 워드프레스 6.4.3 업데이트 공개

Last Updated: 2024년 1월 31일 | | 댓글 남기기

Better Search Replace는 워드프레스 데이터베이스에서 특정 단어 또는 문구를 일괄 변경하는 데 사용하는 인기 워드프레스 플러그인 중 하나입니다.

이 플러그인은 현재 100만 개가 넘는 사이트에 설치되어 사용되고 있습니다. Better Search Replace 플러그인에서 보안 취약점이 발견되어 최신 버전에서 수정되었습니다.

또한, 2024년 1월 30일에 보안 문제가 수정된 워드프레스 6.4.3 업데이트가 공개되었습니다. 워드프레스와 플러그인, 테마 등을 최신 버전으로 업데이트하여 안전하게 사이트를 운영하시기 바랍니다.

워드프레스 Better Search Replace 플러그인 보안 취약점 패치

워드프레스 Better Search Replace 플러그인

워드프레스에서 특정 문구를 찾아서 전체적으로 변경하고 싶은 경우가 있을 수 있습니다. 이런 상황에서 Better Search Replace 플러그인을 사용하면 편리합니다.

DB가 너무 큰 경우에는 에러가 발생할 수 있지만, 일반적인 사이트에서는 문제 없이 작동할 것입니다.

Better Search Replace 플러그인 버전 1.4.4 이하에서 Unauthenticated PHP Object Injection 보안 취약점이 발견되어 1.4.5 버전에서 해결되었습니다.

참고로 Unauthenticated PHP Object Injection은 PHP 웹 애플리케이션에서 발생할 수 있는 심각한 보안 취약점 중 하나이며 PHP의 '직렬화' 및 '역직렬화' 기능과 관련이 있다고 합니다.

Wordfene 문서에 의하면 Better Search Replace 플러그인에서 발견된 취약점을 악용하여 인증되지 않은 공격자가 PHP Object를 주입할 수 있다고 합니다.

한국인터넷진흥원(Korea Internet & Security Agency, KISA)에서도 보안공지를 통해 이 플러그인의 보안 업데이트를 권고하고 있습니다.

취약점제품명(플러그인)영향 받는 버전해결 버전
CVE-2023-6933Better Search Replace1.4.4 버전 이하1.4.5 버전

이 플러그인을 사용하는 경우 반드시 최신 버전으로 업데이트하거나, 당장 필요하지 않는 경우 삭제하시기 바랍니다.

이런 종류의 플러그인은 필요할 때에만 설치하여 사용하고, 목적을 달성한 후에는 삭제하는 것이 좋습니다.

Popup Builder 플러그인 보안 문제

인기 팝업 플러그인 중 하나인 Popup Builder 플러그인에서 심각한 Stored XSS 취약점이 발견되어 4.2.3 버전에서 수정되었습니다. 이 플러그인을 사용하는 경우에도 최신 버전으로 업데이트하시기 바랍니다.

이 플러그인의 보안 패치가 2023년 12월 11일에 이루어졌고, 12월 13일부터 이 보안 취약점을 악용하는 멀웨어(악성코드)가 배포되기 시작했습니다. 보안업체인 Sucuri에서 2024년 1월 10일에 Popup Builder 플러그인의 보안 취약점에 대한 자세한 정보를 공개했습니다.

취약점제품명(플러그인)영향 받는 버전해결 버전
CVE-2023-6000Popup Builder4.2.2 버전 이하4.2.3 버전

워드프레스 6.4.3 업데이트 공개 - 보안 및 유지보수 릴리스

2024년 1월 30일(우리나라 시각으로 2024년 1월 31일 새벽)에 워드프레스 6.4.3 버전이 공개되었습니다.

워드프레스 6.4.3 업데이트

워드프레스 버전 6.4.3에서는 몇 가지 보안 문제가 해결되고 21가지 버그가 수정되었습니다.

Version 6.4.3 문서에 의하면 두 가지 보안 문제가 이번 버전에서 수정되었습니다. 그리고 코어에서 5개의 버그와 블록 에디터(Block Editor)에서 16개의 버그가 해결되었다고 합니다.

워드프레스 6.4.3은 마이너 업데이트이므로 대부분의 사이트에서 자동으로 업데이트가 되었을 것입니다. 자동으로 업데이트가 되지 않았다면 알림판 » 업데이트에서 업데이트 버튼을 클릭하여 업데이트하시기 바랍니다.

대부분의 사이트에서 문제가 발생하지 않지만, 드물게 업데이트 후 문제가 나타날 수도 있으므로 중요한 사이트인 경우 전체 백업을 한 후에 진행하시기 바랍니다.

참고


댓글 남기기

Leave a Comment