워드프레스 업데이트 시 주의사항 - 워드프레스 정보꾸러미
베스트셀링 인기 워드프레스 테마 Top 30 자세한 정보

워드프레스 업데이트 시 주의사항

Last Updated: 2022년 5월 27일 | 2개 댓글
  • 네이버 블로그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

며칠 전에 워드프레스 6.0 버전이 출시되었습니다. 워드프레스는 비교적 자주 업데이트가 됩니다. 워드프레스 사이트를 안전하게 운영하려면 가능하면 최신 버전으로 업데이트하는 것이 바람직합니다. 워드프레스 업데이트 시 사이트 오류가 발생할 수 있으므로 먼저는 백업을 실시하는 것이 좋습니다.

워드프레스 업데이트를 실시하기 전에 아래 사항을 참고해보세요.

워드프레스 업데이트 시 주의사항

워드프레스 업데이트 시 주의사항

업데이트 전 백업하기

저는 관리 중인 모든 사이트를 6.0 버전으로 업데이트했지만 오류가 발생하는 사이트는 없었습니다. 하지만 메이저 업데이트인 경우 사이트 오류가 발생할 수 있습니다. 먼저는 백업을 실시한 후에 업데이트하는 것이 바람직합니다.

중요한 사이트인 경우에는 반드시 백업 후에 업데이트할 것을 강력하게 권장합니다. 백업 방법은 다양합니다. 웹서버 공간이 충분하다면 UpdraftPlus와 같은 무료 플러그인을 사용하여 백업할 수 있습니다.

워드프레스 업데이트 후에 테마나 플러그인이 문제를 일으키는 경우가 있을 수 있는데, 그러면 테마나 플러그인 개발자가 버그가 수정된 패치를 내놓을 수 있습니다. 메이저 업데이트가 릴리스되면 며칠 정도 기다렸다가 업데이트하는 것도 괜찮은 방법일 수 있습니다.

경우에 따라 테스트 사이트를 만들어서 업데이트를 먼저 실시해본 후에 업데이트 적용 시 오류가 발생하는지 체크해볼 수도 있습니다.

업데이트 순서: 테마/플러그인을 먼저 업데이트하세요

경우에 따라 업데이트 순서가 중요할 수도 있습니다.

잘 작동하던 사이트가 워드프레스 코어 버전이 업데이트된 후에 테마나 플러그인이 문제를 일으킬 수 있습니다. 그러면 테만/플러그인 개발자가 오류를 수정한 업데이트를 공개할 수 있습니다.

그러므로 워드프레스와 테마, 플러그인 업데이트가 동시에 나와 있는 경우, 워드프레스를 업데이트하기 전에 테마와 플러그인을 먼저 업데이트하는 것이 오류를 줄이는 방법일 수 있습니다. (워드프레스 업데이트가 공식적으로 릴리스되기 전에 테마/플러그인 개발자들이 미리 새로운 WordPress 버전에서 테스트하여 버그와 오류를 수정한 업데이트를 내놓게 됩니다.)

실제로 워드프레스에서 다국어 사이트를 운영할 때 사용되는 WPML은 워드프레스 6.0 버전에서 분류(Taxonomy) 관련 이슈가 있었습니다. WPML은 워드프레스 6.0이 공식 릴리스되기 전에 해당 오류를 수정한 업데이트를 내놓았습니다.

WPML을 사용하는 경우, 반드시 WPML 업데이트를 먼저 실시한 후에 워드프레스를 업데이트해야 사이트 에러가 발생하지 않습니다. WPML은 이메일을 통해 사용자들에게 이러한 사실을 고지했습니다.

업데이트에 실패하는 경우

워드프레스나 테마, 플러그인을 업데이트할 때 업데이트에 실패하는 경우가 있을 수 있습니다. 워드프레스, 테마, 플러그인 설치/업데이트 시에 오류가 발생하면 다음 사항을 확인해보시기 바랍니다.

  1. 웹호스팅 용량이 부족하지 않은가?
  2. 파일/폴더 권한이 올바르게 설정되었는가?
  3. PHP 버전과 호환이 되는가?
  4. (테마/플러그인의 경우) 워드프레스 버전과 호환이 되는가?

설치/업데이트에 실패하는 흔한 경우가 웹호스팅 웹서버 용량 부족입니다. 먼저 웹서버 디스크 공간이 충분한지 확인해보시기 바랍니다. 국내 호스팅에서 공간을 제한하는 상품이 많습니다. 많은 공간이 필요한 경우 해외호스팅을 고려해볼 수 있습니다. 국내 호스팅의 경우, 저는 최근 나우호스팅이라는 업체에서 워드프레스를 테스트해본 적이 있는데,넉넉한 디스크 공간을 제공하고 비용도 다른 국내 호스팅에 비해 저렴한 편인 것 같습니다("가성비 좋은 국내 호스팅 나우호스팅" 참고).

파일/폴더 권한 문제가 의심되면 서버 관리자나 웹호스팅 고객센터로 연락하여 이 문제를 상의해보시기 바랍니다.

PHP 버전이 낮을 경우 에러가 발생할 수 있습니다. 일부 플러그인에는 워드프레스 버전 및 PHP 버전 요구사항이 있습니다. 예를 들어, ProfilePress라는 멤버십, 사용자 회원가입, 로그인 폼 및 사용자 프로필 플러그인은 PHP 7.1 이상에서만 작동합니다.

워드프레스 플러그인 - PHP 버전 요구 사항

PHP 버전이 낮은 경우:

  1. PHP 버전을 (이 글 작성 시점 기준으로) 7.4 이상으로 업그레이드합니다.
  2. 또는, 다른 비슷한 플러그인으로 교체합니다.

가능한 경우 PHP 버전을 최신 버전으로 변경하는 것이 바람직합니다. PHP 버전이 너무 오래 되면 워드프레스가 작동하지 않을 수 있고, 테마나 플러그인이 오류를 일으킬 수도 있습니다.

테마나 플러그인이 워드프레스 버전과 호환이 안 되어 문제를 일으키는 경우도 있습니다.

워드프레스 업데이트 후 문제가 발생하는 경우

워드프레스 업그레이드 후에 문제가 발생한다면:

  1. 사이트를 롤백합니다.
  2. 또는, 문제를 일으키는 원인을 찾아서 해결합니다.

먼저는 문제를 일으키는 원인을 찾아서 해결하는 것이 좋습니다. 플러그인 충돌이라면 문제가 되는 플러그인 개발자에게 연락하여 문제 수정을 요청할 수 있고, 중요하지 않은 플러그인이라면 삭제하는 것도 고려할 수 있습니다. 또는, 비슷한 기능의 다른 플러그인으로 교체하는 것도 생각할 수 있습니다.

중요한 플러그인이나 테마에서 오류를 일으키고 문제를 해결할 수 없다면 백업본을 이용하여 사이트를 이전 상태로 롤백(복원)하시기 바랍니다. 카페24 등 일부 호스팅에서는 어제 버전으로 롤백하는 옵션도 제공하므로 쉽게 이전 상태로 복원할 수 있습니다.

워드프레스 업데이트 후 문제나 다른 워드프레스 관련 문제로 어려움을 겪는 경우 여기에서 서비스(유료)를 의뢰하실 수 있습니다.

참고



2 개 댓글

Leave a Comment

    • 보통은 문제를 일으키지 않지만 드물게 워드프레스를 먼저 업데이트한 후에 테마나 플러그인을 업데이트했을 때 문제를 일으키는 경우가 있습니다.
      5월의 마지막 날입니다. 5월 한 달 잘 마무리하시기 바랍니다.

      응답