워드프레스 권장 PHP 버전이 7.3으로 바뀌었습니다 - 워드프레스 정보꾸러미
베스트셀링 인기 워드프레스 테마 Top 30 자세한 정보

워드프레스 권장 PHP 버전이 7.3으로 바뀌었습니다

Last Updated: 2020년 11월 14일 | 9개 댓글
  • 네이버 블로그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

오늘 확인해보니 워드프레스 권장 PHP 버전이 7.3으로 변경되어 있네요. PHP 7.3은 2018년 12월 6일에 공식 릴리즈되었으며, 우연의 일치로 WordPress 5.0도 이 날에 정식으로 공개되었습니다.

PHP 버전 7.3 이상

MySQL 버전 5.6 이상 또는 MariaDB 버전 10.0 이상

HTTPS 지원

카페24 등에서는 아직 PHP 7.0까지 지원되고 있습니다. 해외호스팅 중 하나인 Bluehost의 경우 PHP 7.2까지 지원하고 SiteGround에서는 PHP 7.3까지 지원하고 있습니다.

하지만 PHP 7.3이 공식 배포된 지 얼마 되지 않았기 때문에 일부 워드프레스 테마와 플러그인이 PHP 7.3에서 오류가 발생할 수 있습니다. 당분간은 PHP 7.2를 사용하다가, 시간이 조금 지나면서 웹호스팅 업체에서 PHP 7.3을 지원해주면 PHP 7.3으로 넘어가면 될 것 같습니다.

PHP 5는 더 이상 보안 패치가 제공되지 않으므로 가급적 PHP 7로 업그레이드하는 것이 좋습니다(참고). 그리고 속도 측면에서도 이득입니다.

워드프레스 권장 PHP 버전이 7.3으로 바뀌었습니다 2
워드프레스 5에서 PHP 5 / PHP 7.0 / PHP 7.1 / PHP 7.2 / PHP 7.3 속도 테스트 (출처: https://kinsta.com/blog/php-benchmarks/)

Kinsta 벤치마킹에 의하면 워드프레스 5에서 PHP 5.6일 때보다 PHP 7.0을 적용했을 때 속도가 2배 이상 빨라집니다. 그리고 PHP 버전이 높아질 수록 속도가 조금씩 빨라지는 것을 확인할 수 있습니다.

참고:



9 개 댓글

Leave a Comment

  1. 안녕하세요. 저는 라이트세일을 사용하고 있는데요. 라이트세일에서 php 7.3으로 업그레이드 하는 방법 아실까요? 구글링해도 관련 정보 얻기가 힘드네요..참고로 현재 버전은 7.0이에요.

    응답
    • 안녕하세요, 재윤님.

      웹서버가 Apache 서버인가요, 아니면 ngnix 서버인가요?

      SSH에 로그인한 후에 다음 명령을 실행하여 확인할 수 있습니다.

      $ httpd -v

      Apache 서버라면 다음과 비슷하게 표시될 것입니다.

      Server version: Apache/2.4.16 (Unix)

      nginx 서버인 경우:

      $ nginx -v

      결과 예시:
      Nginx version: nginx/1.14.0 (Ubuntu)

      응답
    • 안녕하세요?

      확인해보니 "라이트세일의 wordpress는 현재 기준으로 우분투 16.04, 워드프레스 5.3.2가 설치가 됩니다. php 버전은 7.3.14가 인스톨"된다고 합니다. 그러므로 새로운 워드프레스 인스턴스를 설치하고 현재 워드프레스 사이트를 새로운 인스턴스로 이전하는 것을 고려해보시기 바랍니다.

      이 방법이 이전 과정이 조금 복잡하게 느껴져도, 현재 서버(인스턴스)의 PHP 버전을 업그레이드하는 것보다 문제를 야기할 가능성이 낮을 것입니다.

      응답
  2. 안녕하세요 🙂
    Php 기존 5.6에서 7로 업데이트 했더니 홈페이지가 안뜹니다 ㅠㅠ

    Fatal error: Cannot use "self" when no class scope is active in /host/home1/hyesungch/html/wp-content/themes/Avada/framework/plugins/importer/importer.php on line 1000
    There has been a critical error on your website.

    Learn more about debugging in WordPress.

    이런 오류가 나오네요 ㅠㅠ avada 테마가 php7버전에 대응이 안돼서 그런걸까요..?

    응답
    • 안녕하세요, 류명한님

      아바다 테마도 최신 버전으로 업데이트하셨나요?
      그리고 워드프레스 코어, 플러그인도 모두 최신 버전으로 업데이트되어 있는지도 확인하세요.
      (백업을 미리 하실 것을 권장합니다.)

      PHP 버전을 7.3이나 7.2로 설정하면 문제는 발생하지 않을 것입니다.

      응답
  3. 이 글을 작성한 후에 변화가 있었습니다.

    현재 블루호스트에서는 PHP 7.3까지 지원하고 사이트그라운드는 PHP 7.4까지 지원합니다.

    워드프레스가 PHP 7.4에서도 돌아가지만, 일부 테마나 환경에서 문제를 일으킬 수 있습니다.

    https://www.thewordcracker.com/basic/php-7-4-%EB%B2%84%EC%A0%84%EA%B3%BC-%EC%9B%8C%EB%93%9C%ED%94%84%EB%A0%88%EC%8A%A4-%ED%98%B8%ED%99%98%EC%84%B1/

    응답
  4. 헐 대박 몇달전부터 이 사이트를 알고 나서 듬성듬성 워드프레스 공부할때 도움받았는데
    일반블로그인지 댓글보고 처음 알았네요. 무슨 워드프레스 공식사이트나 포럼인줄알았는데 ㄷ
    도움많이 받고 있는데 이런 블로그 만들어주셔서 감사합니다.

    응답

카페에서 워드프레스 정보를 공유하실 수 있습니다.

Thanks!