워드프레스에서 ‘이 작업을 수행하시겠습니까?’ 오류가 발생하는 경우

참고: 인기 테마인 BE 테마(33%)The 7(35%) 할인 행사를 진행하고 있습니다.
참고

이 작업을 수행하시겠습니까? 오류

워드프레스에서 ‘이 작업을 수행하시겠습니까? (Are you sure you want to do this?)‘ 오류가 발생하는 경우가 있을 수 있습니다.

wpbeginner에 의하면 이 오류는 보통 워드프레스에서 관리자 URL의 Nonce를 체크하지만 체크가 실패하는 경우에 발생한다고 합니다. Nonce는 검증 목적으로 테마, 플러그인 또는 코어 WordPress 파일에서 생성할 수 있는 키 또는 숫자입니다. Nonce는 보안 레이어를 추가하여 워드프레스 URL, 양식, ajax 호출을 악용으로부터 보호하는 역할을 합니다.

‘이 작업을 수행하시겠습니까?’ 오류는 Nonce 검증이 실패할 때 흔히 나타나며 플러그인이나 테마에서 Nonce를 제대로 사용하지 못하는 경우에 발생할 가능성이 높습니다.

문제 해결 방법

‘이 작업을 수행하시겠습니까? 오류는 위에서 언급했듯이 플러그인이나 테마가 원인일 가능성이 높습니다. 모든 플러그인을 비활성화하여 문제를 야기하는 플러그인이나 테마를 찾도록 합니다. “워드프레스에서 모든 플러그인을 비활성화하는 방법“을 참고해보시기 바랍니다.

추가 고려 사항

이 문제를 조사하다가 PHP 구성 제한 때문에도 이 문제가 발생할 수 있다는 것을 발견했습니다. 다음과 같은 PHP 구성의 값을 높여보면 문제가 해결될 수 있습니다.

  • max_execution_time 60
  • memory_limit 128M
  • post_max_size 48M
  • upload_max_filesize 48M

memory_limit 값과 max_execution_time 값을 설정하는 방법은 “Wp_memory_limit 및 Max_execution_time 설정 변경하기” 글에서 설명되어 있습니다. post_max_size 값과 upload_max_size 값 설정 방법은 “파일 업로드 크기 설정 변경하기” 글을 참고해보시기 바랍니다.

또한, 사용 중인 웹호스팅의 PHP 버전도 워드프레스나 테마에서 권장하는 요구 사항에 부합하는지도 확인하시기 바랍니다. 가령, 워드프레스 베스트셀링 테마인 Avada가 최근 업데이트되면 성능이 더욱 향상되었지만, 동시에 PHP 버전 때문에 문제가 발생하는 경우가 자주 목격됩니다. 아바다의 경우 PHP 5.6 이상을 권장합니다(참고). Enfold도 PHP 5.5 이하에서는 일부 문제가 나타난다고 호소하는 분들이 계십니다. 따라서 가급적 PHP 5.6 이상을 사용해야 예상치 못하는 문제를 예방할 수 있을 것입니다.



기부를 통해 이 블로그를 후원하실 수 있습니다.
워드프레스 설치/제작/문제해결이 필요한 경우 서비스(유료)를 요청해주세요.