워드프레스 5.5.1 업데이트 - 유지보수 및 보안 릴리즈

  • 네이버 블로그 공유하기
  • 네이버 밴드에 공유하기
  • 페이스북 공유하기
  • 트위터 공유하기
  • 카카오스토리 공유하기

오늘 새벽에 워드프레스 5.5.1 업데이트가 공개되었습니다. 이번 업데이트는 유지보수 및 보안 릴리즈로 44개의 버그가 해결되었습니다. 가급적 최신 버전으로 워드프레스를 업데이트하시기 바랍니다.

워드프레스 5.5.1 업데이트 - 유지보수 및 보안 릴리즈

워드프레스 5.5.1 업데이트 - 유지보수 및 보안 릴리즈

워드프레스 5.5가 공개된 지 3주만에 버그가 수정된 5.5.1 버전이 릴리즈되었습니다. WordPress 5.5는 메이저 업데이트로 속도, 보안, SEO적인 측면에 중점을 두고 업데이트가 이루어졌습니다.

이미지 레이지 로딩 기능이 추가되어 속도가 개선되었으며 SEO를 위해 코어에 XML 사이트맵이 포함되었습니다. 그리고 보안을 위해 테마와 플러그인을 자동으로 업데이트하는 옵션이 추가되었습니다.

모든 플러그인을 자동으로 업데이트되도록 설정하거나 일부 플러그인만 자동 업데이트가 되도록 할 수 있습니다.

전체 플러그인 또는 선택한 플러그인에 대하여 자동 업데이트 기능을 활성화하려면 플러그인 이름 앞의 체크란을 선택하고 Bulk actions 드롭다운을 클릭한 다음 Enable Auto-updates (자동 업데이트 활성화)를 선택한 다음 적용을 클릭하면 됩니다.

워드프레스 5.5에서 플러그인 자동 업데이트 설정

자동 업데이트를 비활성화하려면 Disable Auto-updates (자동 업데이트 비활성화)를 클릭하면 자동 업데이트 기능이 사용 중지됩니다. 개별적으로 자동 업데이트를 활성화하려면 자동 업데이트를 원하는 플러그인의 맨 오른쪽에 있는 (Automatic Updates 열 아래의) Enable auto-updates를 클릭하도록 합니다. (유료 플러그인은 이 기능으로 자동 업데이트를 설정할 수 없습니다.)

워드프레스 5.5.1에서는 34개의 버그 수정과 4개의 기능 향상이 이루어졌고 블록 에디터(구텐베르크)의 버그 5개도 해결되었다고 합니다. 가능한 경우 최신 버전으로 업데이트하시기 바랍니다. 중요한 사이트인 경우 반드시 백업을 실시한 후에 업데이트를 진행하도록 하세요.

워드프레스 5.5.1에서 변경된 사항에 대한 자세한 내용은 워드프레스 5.5.1 릴리즈 노트를 참조하시기 바랍니다.

워드프레스 5.5 업데이트 후 사이트가 깨지는 문제가 발생하는 경우

워드프레스 5.5 업데이트 후에 사이트가 깨지는 문제가 발생할 수 있습니다. 워드프레스 5.5에서는 구형 코드로 빌드된 워드프레스 플러그인과 테마가 올바르게 작동하도록 워드프레스에 오랫동안 포함되었던 jQuery Migrate가 비활성화되었습니다. jQuery Migrate의 사용이 중지됨에 따라 오래된 테마나 플러그인이 제대로 작동하지 않기 때문에 일부 워드프레스 사이트가 깨질 수 있습니다.

워드프레스를 5.5 버전으로 업데이트한 후에 사이트 레이아웃이 깨지는 경우 다음 글을 참고하여 문제 해결을 시도해보시기 바랍니다.

마치며

이 블로그를 통해 거듭 강조하는 내용이지만 안전하게 사이트를 운영하기 위해서는 워드프레스, 테마, 플러그인을 항상 최신 버전으로 유지하고 오랫동안 업데이트가 안 되는 플러그인이나 테마는 사용하지 않는 것이 바람직합니다. 그리고 정기적으로 백업을 실시하여 PC나 클라우드 스토리지에 보관하면 만약의 사태가 발생할 경우에 사이트 복구가 가능합니다.

워드프레스 5.5.1 버전은 마이너 업데이트이기 때문에 대부분의 사이트에서 문제가 발생하지 않을 것 같지만, 중요한 사이트인 경우 업데이트를 진행하기 전에 백업을 받는 것이 안전합니다.

참고



댓글 남기기