워드프레스 LMS 플러그인 LearnPress 보안 업데이트

LearnPress는 인기 LMS 테마인 Eduma를 만든 ThimPress에서 만든 워드프레스 LMS 플러그인입니다. LearnPress 플러그인의 최신 업데이트에서 최근 권한 상승(Privilege Escalation) 보안 취약점이 수정되었습니다.

워드프레스 LMS 플러그인 LearnPress

워드프레스 LMS 사이트 구축

워드프레스에서 인터넷 강의 사이트나 교육용 사이트를 구축하는 경우 쉬운 방법으로 인기 LMS 워드프레스 테마인 Eduma와 같은 테마를 사용하는 것입니다.

하지만 LMS 사이트 구축 경험이 있는 전문 개발자에 의하면 상용 서비스를 목표로 한다면 LMS 테마를 사용하는 것보다 Divi 테마 + LeanDash 조합으로 만드는 것이 바람직하다고 합니다. 이 경우 난이도가 있는 작업이기 때문에 전문업체에 의뢰하면 좋은 결과를 얻을 수 있을 것 같습니다.

LMS 플러그인에는 ThimPress가 개발한 LearnPress 외에 LifterLMS가 있습니다. LifterLMS 플러그인에 대한 자세한 내용은 "워드프레스 LMS(학습관리시스템) 플러그인 LifterLMS 스크린샷"을 참고해보세요.

워드프레스 LMS 플러그인 LearnPress

워드프레스 LMS 플러그인 LearnPress

LearnPress는 워드프레스 Moodle과 같은 종합적인 LMS 플러그인입니다. 이 플러그인을 사용하여 쉽게 온라인 코스를 만들어 판매할 수 있습니다. 각 코스 커리큘럼은 사용이 쉬운 인터페이스로 관리할 수 있는 레슨(Lesson)과 퀴즈(Quiz)로 구성될 수 있습니다. 이 LMS 플러그인으로 코딩 지식이 없어도 교육용 웹사이트, 온라인 스쿨, 인강 웹사이트를 구축할 수 있습니다.

LearnPress 플러그인에서 권한 상승(Privilege Escalation) 취약점이 발견되어 최신 버전(현재 최신 버전 3.2.6.7)에서 수정되었습니다. 패치되지 않은 플러그인을 사용하면 인증된 사용자가 자신의 역할을 강사/교사(instructor/teacher)로 변경하여 접근이 제한된 데이터에 접근할 수 있으므로, 이 플러그인을 사용하는 경우 최신 버전으로 업데이트하시기 바랍니다.

마치며

워드프레스는 보안에 강하지만 사이트를 제대로 관리하지 못하면 멀웨어나 해킹 등에 노출될 수 있습니다. 가능한 경우 항상 최신 버전으로 워드프레스코어, 테마, 플러그인을 업데이트하고 강력한 비밀번호를 사용하는 등 보안 관행을 준수하면 안전하게 홈페이지를 운영할 수 있을 것입니다.

정기적으로 사이트를 백업하면 만약의 사태가 발생해도 사이트를 쉽게 복구할 수 있습니다. 웹호스팅에서 제공하는 백업 서비스나 워드프레스 플러그인을 사용하여 백업본을 만들 수 있습니다("DB와 데이터를 모두 백업하는 백업/복원 플러그인 - UpdraftPlus WordPress Backup" 참고).

참고:


댓글 남기기