워드프레스 4.9.2 업데이트 – 보안 및 유지보수 릴리스

0

워드프레스가 4.9.2로 업데이트되었습니다. 4.9.2는 워드프레스 3.7 이후의 모든 버전에 대한 보안 및 유지보수 릴리스이므로 즉시 사이트를 업데이트할 것을 워드프레스에서 적극 권장하고 있습니다.

워드프레스에 포함된 라이브러리 중 하나인 MediaElement의 Flash fallback 파일에서 XSS 취약점이 발견되었습니다. 플래시(Flash) 파일은 대부분의 경우 더 이상 필요하지 않으므로 워드프레스에서 제거되었습니다.

MediaElement는 버그를 수정한 새로운 버전을 내놓았으며 플러그인 저장소에서 수정된 파일이 포함된 워드프레스 버전을 다운로드할 수 있습니다.

워드프레스 4.9.2에서는 이외에도 다음을 포함한 21가지 버그가 수정되었습니다.

  • 파이어폭스(Firefox)에서 글을 저장하지 못하게 하는 자바스크립트(JavaScript)가 수정되었습니다.
  • get_category_link()category_description()의 이전 taxonomy-agnostic 동작이 복원되었습니다.
  • 테마를 변경하면 매핑할 사이드바가 없는 경우에도 이제 이전 위젯 배정을 복원하려고 시도합니다.

워드프레스 4.9.2에서 수정된 모든 문제에 대한 자세한 내용은 Codex 문서에서 살펴볼 수 있습니다.

항상 강조하지만 워드프레스는 보안에 강하지만 업데이트를 소홀히 하거나 보안에 취약한 플러그인의 사용으로 인해 보안에 문제가 발생할 수 있습니다. 자동으로 업데이트가 안 되는 경우 즉시 새로운 버전으로 업데이트하시기 바랍니다.

그리고 보안을 위해 보안 플러그인을 설치(워드프레스 베스트 보안 플러그인 참고)하고 정기적으로 백업을 실시하는 것이 좋습니다.

Related Posts