워드프레스 테마 설치 에러

워드프레스 포럼 게시판 Forum 워드프레스 테마 설치 에러

이 게시글은 0개 답변과 1명 참여가 있으며 마지막으로  Word Cracker에 의해 2016년 10월 29일 업데이트 됐습니다.

  • 글쓴이

  • Word Cracker
    Keymaster

    워드프레스 유로 테마 구매해서 다운받은 압축파일 그대로 업로드했는데요. 워드프레스 일림판에서 테마 활성화하려고 하니 이렇게 뜨더라구요.

    Parse error: syntax error, unexpected T_PAAMAYIM_NEKUDOTAYIM in …/wp-content/themes/stockholm/framework/lib/qode.layout.php on line 2711

    2711번째 줄은 아래에서 요거구요.

    update_option($twitterApi::AUTHORIZE_TOKEN_FIELD, $_GET[‘oauth_token’]);

    이게 어느 부분이 잘못된 건가요? PHP는 잘 몰라서 파일 열어봐도 몰라서요…

    워드프레스 설치 오류


    답변:

    아마 스톡홀름(Stockholm) 테마를 사용하시는 것 같네요. 테마포레스트를 살펴보니 Stockholm은 지난 주 판매 수량으로 22위를 기록한 인기 테마 중 하나이네요.

    위와 비슷한 문제가 아바다(Avada) 테마에서도 나타나는 것을 본 적이 있습니다:

    아바다 테마에서는 PHP 버전이 5.6 이상이 되어야 하지만 웹호스팅 서버의 버전이 낮아서 위와 같은 문제가 발생했습니다.

    먼저 웹호스팅 서버의 PHP 버전을 확인하시고 가급적이면 PHP 5.6 이상으로 업데이트해보시기 바랍니다. 참고로 Enfold 테마도 카페24의 PHP 5.5에서 글 편집 시 로딩이 지연되는 등의 문제가 발생한다고 호소하는 분도 본 적이 있습니다.

    참고로 WordPress에서는 PHP 5.6 버전 이상을 권장합니다.

    https://wordpress.org/about/requirements/

    PHP 5.6 or greater (PHP 5.6 이상)
    MySQL 5.6 or greater (PHP 5.6 이상)
    The mod_rewrite Apache module (mod_rewrite Apache 모듈)

'워드프레스 테마 설치 에러'에 답변달기
글쓴이 정보: