테마에 포함된 비주얼 컴포저를 워드프레스 업데이트 시 사용 불가능 현상

워드프레스 포럼 게시판 Forum 테마에 포함된 비주얼 컴포저를 워드프레스 업데이트 시 사용 불가능 현상

이 게시글은 0개 답변과 1명 참여가 있으며 마지막으로  Word Cracker에 의해 2016년 5월 2일 업데이트 됐습니다.

  • 만든이
    게시글
  • #160 답변

    Word Cracker
    Keymaster

    안녕하세요. 궁금한 사항 있어 글 씁니다.

    유료 워드프레스 템플릿을 하나 구매했고 템플릿에 비주얼 컴포저(Visual Composer)가 포함되어 있었습니다.

    기존에 잘 사용하고 있었으나, 워드프레스를 업데이트하자 비주얼 컴포저(Visual Composer)를 사용할 수 없게 되었네요.

    원래 템플릿에 포함되어 제공되는 유료 플러그인의 경우 이런 게 맞는 건지 궁금하네요

    해당 플러그인을 계속 쓰고 싶으면 워드프레스 업데이트를 하지 않아야 하는 건지, 추가 비용으로 플러그인 구매 없이는 해당 플러그인을 사용 못하는 건지 ..궁금합니다.


    답변:

    워드프레스가 업데이트하기 전에 워드프레스에서 개발자들에게 업데이트 내용을 알려서 새로운 워드프레스 버전에서 테마나 플러그인이 업데이트되도록 조치를 취합니다. 하지만 간혹 테마나 플러그인이 새로운 워드프레스 버전에 맞게 수정을 하지 않을 경우 호환성 문제가 발생하곤 합니다.

    그래서 새로운 워드프레스가 발표되면 곧바로 업데이트를 하지 말고, 테마와 사용 중인 플러그인이 업데이트된 워드프레스와 호환되 되는지, 문제가 없는지 확인한 후에 업데이트를 단행하는 것이 안전합니다. 개인 블로그는 크게 상관 없겠지만 기업용으로 워드프레스를 사용하는 경우 테스트 사이트에서 미리 업데이트를 해 본 후에 아무 이상이 없음을 확인하고 업데이트를 실시하는 것이 바람직할 것입니다.

    (2016년 5월 초) 현재, 최근 워드프레스가 4.5대로 업데이트가 있었습니다. 이로 인해 Visual Composer를 포함한 일부 플러그인이나 테마에 호환성 문제가 발생하고 있습니다. 특히 테마에 포함된 Visual Composer의 경우 테마에서 업데이트를 해주지 않으면 당분간 이전 버전의 워드프레스를 사용해야 할 것 같습니다. 문제가 발생할 경우, 테마에서 업데이트를 발표한 후에 테마와 함께 워드프레스를 업데이트하실 것을 권장합니다.

    우선은 복원 기능을 사용하여 문제가 발생하기 전으로 복원하시거나, 수동으로 워드프레스를 다운그레이드하시기 바랍니다. 카페 24와 같은 일부 웹호스팅 업체에서는 복원 기능을 제공합니다(참고). 만약 복원이 용이하지 않은 경우 이 글을 참고로 워드프레스를 다운그레이드할 수 있습니다.

'테마에 포함된 비주얼 컴포저를 워드프레스 업데이트 시 사용 불가능 현상'에 답변달기
글쓴이 정보: