테마의 Visual Composer 업데이트 가능 여부

워드프레스 포럼 게시판 Forum 테마의 Visual Composer 업데이트 가능 여부

이 게시글은 0개 답변과 1명 참여가 있으며 마지막으로  Word Cracker에 의해 2016년 10월 1일 업데이트 됐습니다.

  • 만든이
    게시글
  • #221 답변

    Word Cracker
    Keymaster

    워드프레스 4.0 버전에 Total 테마를 설치하여 홈페이지를 운영하고 있습니다. 워드프레스를 최신 버전으로 업데이트를 하니 Total 테마에 있는 비주얼 컴포저(Visual composer)가 작동을 하지 않고 있습니다.

    비주얼 컴포저 버전은 4.3입니다. VC 버전을 업데이트해야 하나요? Total 테마에 있는 비주얼 컴포저 버전만 업데이트할 수 있나요?


    답변:

    워드프레스(WordPress)가 업데이트되면 테마나 플러그인과 예상치 못한 호환성(Compatibility) 오류가 발생하는 경우가 종종 있습니다.

    특히 비주얼 컴포저(Visual Composer)는 오류 발생 가능성이 높습니다. (비주얼 컴포저가 인기가 많지만 실제 평가에서는 그리 좋은 평가를 받지 못하고 있습니다. 페이지 빌더 중에서 가장 좋은 평가를 받는 플러그인은 Beaver Builder라는 플러그인입니다. “워드프레스 페이지 빌더의 장점과 단점” 참고)

    워드프레스 테마 - Total

    Total 테마의 경우 최근(2016년 9월 1일)에 테마가 업데이트된 것으로 나오네요. 이 경우 최신 테마를 설치하면 문제가 해결될 것으로 생각됩니다.

    만약 최신 테마로 업데이트한 후에도 문제가 발생한다면 테마 판매자에게 문의해보는 것이 좋을 듯 합니다. 어쩌면 테마 판매자는 현재 테마가 최신 워드프레스 버전에서 VC와 호환된다고 말할 수도 있습니다. 그런 경우에는 테마나 비주얼 컴포저 문제가 아니라 다른 플러그인과의 충돌을 의심해볼 수 있습니다.

    (혹시 모르니까 테마 판매자에게 VC 최신 버전을 보내달라고 요청하셔도 됩니다. 최신 VC 버전을 테마 판매자에게 요청하면 선뜻 보내주는 판매자가 있지만 그렇지 않고 테마와의 호환성 평가 후에 문제가 없다고 판단되면 그때 보내준다는 분도 있습니다.)

    정리해보면:

    • 최신 버전의 테마를 다운로드하여 업데이트하고, 비주얼 컴포저도 최신 테마 버전에 포함된 버전을 설치하도록 합니다.
    • 계속 문제가 발생하면 테마 판매자와 연락하여 현재 테마가 비주얼 컴포저와 사용 시 문제를 일으키는 지 확인하고, 만약 문제가 없다고 한다면 VC와 다른 플러그인 간의 충돌을 의심해볼 수 있습니다.
    • 최신 비주얼 컴포저를 테마 판매자에게 요청하여 설치해봅니다.

    이 정도가 될 것 같습니다.

    참고로 Total 테마에서 테스트를 마친 비주얼 컴포저(VC) 버전이 있을 수 있습니다. 이 경우 테스트를 마친 버전을 사용하는 것이 좋을 듯 합니다.  비주얼 컴조저만 업데이트가 가능하지만 테마와의 호환성을 담보하지 못할 수 있습니다. 이런 내용은 해당 테마 판매자에게 문의해보면 가장 정확한 답변을 얻을 수 있습니다.

    * 참고: 많은 유료 테마에서 Visual Composer가 기본적으로 탑재되어 제공됩니다. 이 경우 VC의 라이선스는 테마 개발자에게 있으므로 최종 소비자는 테마 개발자를 통해 VC를 업데이트해야 합니다.

'테마의 Visual Composer 업데이트 가능 여부'에 답변달기
글쓴이 정보: