워드프레스 인기 갤러리 플러그인 Nextgen Gallery 보안 업데이트

0

NextGEN Gallery는 3년 전에 이 블로그에서도 다룬 적이 있는 무료 워드프레스 갤러리 플러그인으로 현재 90만 개 이상의 사이트에 설치되어 사용되고 있을 정도로 많은 인기를 얻고 있습니다.

워드프레스 Nextgen Gallery 갤러리 플러그인

이 플러그인에 SQL Injection 보안 결함이 발견되어 3.2.11 버전에서 보안 문제가 수정되었습니다. 이 플러그인을 사용하는 경우 반드시 최신 버전으로 업데이트하시기 바랍니다.

제가 블로그를 시작할 당시에 괜찮은 무료 갤러리 플러그인이 거의 없었습니다. NextGEN Gallery는 무료이지만 비교적 괜찮은 퀄리티를 제공하는 유용한 플러그인 같습니다. 하지만 작년에도 SQL Injection 취약점이 발견되어 보안 결함이 수정된 적이 있습니다. 이 플러그인을 사용하는 경우 특히 최신 버전을 이용하는 것이 안전할 것 같습니다.

워드프레스 자체는 보안에 강하지만 워드프레스, 테마, 플러그인을 최신 버전으로 업데이트하지 않거나 약한 비밀번호를 사용하는 등 보안 관행을 소홀히 하면 사이트가 악성 코드에 감염되거나 해킹 당할 위험이 존재합니다.

항상 강조하는 내용이지만, 1) 워드프레스, 테마, 플러그인을 최신 버전으로 유지하고, 2) 정기적으로 백업하고, 3) 보안 플러그인을 설치하면 안전하게 워드프레스를 운영할 수 있습니다.

가끔 사이트 백업을 제대로 하지 않아서 사이트를 복구하지 못하는 안타까운 사례를 접합니다. 백업을 생활화하여 만약의 사태에 대비하는 것이 무엇보다 중요한 것 같습니다.

웹호스팅 업체에서 백업/복원 기능을 제공하기도 하지만, 워드프레스 플러그인을 사용하여 사이트를 백업할 수도 있습니다.

참고:

댓글 남기기

댓글을 입력해주세요!
이름을 입력해주세요