Google Custom Search(구글 맞춤 검색) 플러그인 문제 – API 변경

0

구글 크롬 브라우저, HTTP 사이트에 안전하지 않음 경고 표시

이 블로그에 설치된 Publisher라는 테마에는 테마 개발자가 자체적으로 만들어 추가한 플러그인이 제법 있습니다. 그 중 하나가 Better Google Custom Search라는 구글 맞춤 검색 플러그인입니다.

구글 맞춤 검색엔진(https://www.google.co.kr/cse/)을 사용하면 등록된 사이트의 컨텐츠를 구글 검색엔진을 사용하여 검색이 가능합니다. 여러 개의 사이트를 등록하면 여러 개의 사이트에서 컨텐츠를 검색할 수 있습니다. 워드프레스 기본 검색 기능이 아닌 구글 검색엔진을 사용하므로 보다 관련성 있는 검색 결과를 얻을 수 있습니다.

며칠 전에 구글 맞춤 검색 플러그인이 제대로 작동하지 않아서 테마 개발자에게 문의를 했습니다. 워드프레스 5.0이 릴리즈되면서 문제가 나타났기 때문에 구텐베르크(Gutenberg)가 원인일 것이라고 생각했습니다.

하지만 이 문제가 기존에 잘 작동하던 워드프레스 4.9.8에서도 나타난다고 하네요. 따라서 워드프레스 문제가 아니라 다른 원인에 의해 이 문제가 발생하고 있다는 것을 짐작할 수 있습니다. 테마 개발자는 구글에서 API를 변경한 것 같다고 하네요.

It seems to google changed the API, we are working on it.
we’ll fix it ASAP.

워드프레스 5.0이 공개된 시점과 구글 맞춤 검색이 작동하지 않은 시점이 묘하게 일치하네요.

구글 맞춤 검색과 관련하여 문제가 발생하는 경우 Google Custom Search Engine(CSE) 사이트에 접속하여 다시 코드를 받아서 대체해보시기 바랍니다.

워드프레스 5.0이 최근 릴리스되었고, 우리나라 시각으로 12월 14일(미국 시각으로 12월 13일)에 워드프레스 5.0.1이 나왔습니다. WordPress 5.0.1은 보안 릴리즈로서 워드프레스 3.7 이상 버전에서 발견된 몇 가지 보안 문제가 해결되었습니다. 그러므로 워드프레스를 최신 버전으로 업데이트하는 것이 좋습니다.

워드프레스 5.0.1에서 수정된 보안 문제 리스트는 워드프레스 뉴스 사이트를 참고해보세요.

현재 이 블로그에 사용해왔던 구글 맞춤 검색 기능을 임시로 비활성화한 상태입니다. 플러그인이 수정되면 다시 적용할 예정입니다. (사파리 브라우저에서도 이 블로그의 구글 맞춤 검색 기능이 제대로 작동하지 않는 버그가 있는 것 같습니다. 이 문제도 수정해줄 것을 개발자에게 요청했습니다.)

워드프레스 5.0으로 업데이트한 후에 구텐베르크 편집기가 문제를 일으키는 경우 ‘Classic Editor’를 설치하여 기본 편집기를 ‘고전 편집기’로 변경할 수 있습니다.

*일부 글에 제휴링크가 포함될 수 있습니다.기부를 통해 블로그 운영을 후원하실 수 있습니다.

Related Posts