패스트코멧 (FastComet): PHP 8.3 적용하기

Last Updated: 2024년 07월 10일 | 댓글 남기기

현재 최신 PHP 버전은 8.3입니다. 하지만 아직 PHP 8.3을 지원하는 웹호스팅 업체는 드문 편입니다. 카페24는 PHP 8.2까지 지원하고 있습니다. PHP 8.3을 지원하는 호스팅 업체로는 사이트그라운드와 패스트코멧 정도가 있습니다.

사이트그라운드는 몇 년 전 우리나라를 비롯한 대부분이 아시아 국가에서 신규 가입을 받지 않고 있습니다. 패스트코멧은 블루호스트와 비슷한 레벨의 해외호스팅 업체이지만, 도쿄 서버 리전을 제공하므로 속도면에서 블루호스트보다 괜찮습니다. 패스트코멧은 최근 (2024년 2월에) PHP 8.4 지원을 추가했습니다.

이 글을 작성할 당시 클라우드웨이즈는 PHP 8.2까지 지원했지만 2024년 7월에 PHP 8.3 지원을 추가했습니다.

📍 클라우드웨이즈 가입 방법 (+ Cloudways 프로모 코드, 할인 쿠폰 코드)

패스트코멧 (FastComet): PHP 8.3 적용하기

PHP 8.3 버전을 적용하여 테스트해보니 최신 워드프레스 버전과 대부분의 인기 테마와 플러그인이 문제 없이 작동하는 것을 확인했습니다. PHP 8.3을 사용해도 워드프레스 호환성에는 문제가 없을 것 같습니다. 그러나 사용자가 별로 없거나 오랫동안 업데이트가 안 되고 있는 테마와 플러그인에서는 제대로 작동하지 않을 수 있을 것입니다.

보안 지원되는 PHP 버전

2024년 2월 현재 보안 지원(Security Support)이 제공되는 PHP 버전은 PHP 8.1, 8.2 및 8.3입니다. PHP 8.0과 PHP 7.4 이하 버전은 보안 지원이 종료되었습니다.

보안 지원이 제공되는 PHP 버전

PHP 버전이 높을 수록 사이트 속도가 빠르고 보안면에서도 유리합니다. 가급적 PHP 8.1 이상을 사용하시기 바랍니다.

카페24를 이용하는 경우에는 PHP 8.2로 업그레이드할 수 있습니다. PHP 7.4 이하에서 PHP 8.2로 변경하면 서버가 바뀌기 때문에 데이터와 DB를 백업하여 업그레이드를 진행해야 합니다.

오래된 PHP 버전을 사용하다 PHP 버전을 8.2로 업그레이드하면 사이트의 일부 테마나 플러그인이 제대로 작동하지 않을 수도 있습니다. PHP 버전 변경이나 워드프레스 관련 문제로 어려움을 겪는 경우 여기에서 서비스(유료)를 의뢰하실 수 있습니다.

패스트코멧에서 PHP 8.3 변경 방법

FastComet을 사용하는 경우 cPanel에 로그인하여 PHP 버전을 선택하고 PHP 환경 설정값을 변경할 수 있습니다.

PHP 버전 변경하기

패스트코멧에 로그인한 다음, Active Products(사용 중인 상품)의 해당 상품에서 cPanel 아이콘을 클릭합니다.

비밀번호 입력 팝업이 표시됩니다. 마스터 패스워드(계정 비밀번호)를 입력하고 PROCEED 버튼을 누릅니다.

패스트코멧 마스터 비밀번호 입력

씨패널(cPanel)에 접속되면 오른쪽 상단의 검색 필드에 "php"를 입력(①)하고 Select PHP Version을 선택(②)합니다.

FastComet 씨패널 화면

PHP Selector 화면이 표시됩니다.

PHP Extensions 탭의 Current PHP version (현재 PHP 버전) 드롭다운을 클릭하고 원하는 PHP 버전을 선택할 수 있습니다.

패스트코멧 PHP 버전 선택기

현재 PHP 5.6 버전에서 PHP 8.3 버전까지 선택할 수 있습니다.

8.3을 선택하고, Apply (적용) 버튼을 클릭하여 적용합니다.

패스트코멧 PHP 버전 변경

PHP 환경 설정값 변경하기

계속하여 Options 탭을 클릭하여 PHP ini 설정값을 지정할 수 있습니다.

패스트코멧 PHP 옵션 설정

max_execution_time, max_input_time, max_input_vars, memory_limit 등의 옵션 값을 적절히 변경하도록 합니다. 예를 들어, memory_limit 값을 512M로 설정할 수 있으며, 최대 1G로 지정할 수 있습니다.

패스트코멧 PHP Memory Limit 제한 크기 설정

Memory Limit 값의 경우 wp-config.php 파일에도 다음 라인을 추가해야 메모리 제한 크기 값이 적용됩니다.

define( 'WP_MEMORY_LIMIT', '512M' );

워드프레스의 도구 » 사이트 건강에서 PHP 버전을 확인할 수 있습니다. (2024년 2월 15일 현재) PHP 8.3.2 버전으로 표시되네요.

참고로 "사이트 건강"은 "Site Health"의 한국어 번역입니다. IT에서 Health는 "상태"로도 번역됩니다. 초기에는 "사이트 상태"로 번역되었지만, 지금은 "사이트 건강"으로 번역이 굳어진 것 같습니다. (개인적으로는 "사이트 상태"가 더 자연스럽지 않나 생각됩니다만, "사이트 건강"이라는 용어로 자주 접하다 보기 익숙해지네요.😄😄)

GeneratePress, 아스트라 등 대부분의 인기 테마와 엘리멘터와 같은 페이지 빌더가 PHP 8.3에서 오류 없이 잘 작동합니다.

만약 문제될 경우 동일한 과정에 따라 PHP 버전을 8.2나 이전 버전으로 되돌리시면 됩니다. 카페24의 경우 PHP 7.x에서 PHP 8.2로 변경하거나 그 반대의 경우 서버가 변경되어 사이트가 초기화되지만 FastComet이나 Cloudways 등에서는 쉽게 PHP 버전을 변경할 수 있습니다.

이 블로그는 블루호스트에서 오랫동안 호스팅되다 작년부터 클라우드웨이즈에서 운영되고 있습니다.

클라우드웨이즈는 아직 PHP 8.2까지 지원되지만, 지난 달에 문의해보니 PHP 8.3과의 호환성을 위해 열심히 작업하고 있다는 답변을 들었습니다. 조만간 PHP 8.3 지원이 추가되지 않을까 기대됩니다. PHP 8.3이 정식 지원되면 곧바로 PHP 8.3으로 전환할 생각입니다.

참고


댓글 남기기

Leave a Comment