자동 업데이트 버그가 수정된 워드프레스 4.9.4 업데이트 릴리스

2

워드프레스 유지관리 릴리스

어제 워드프레스가 4.9.3으로 자동으로 업데이트된 후에 오늘 새벽에 4.9.4 버전이 나왔습니다.

4.9.3 버전에서 자동 백그라운드 업데이트 기능이 제대로 작동하지 않는 ‘심각한(?)’ 버그가 있었습니다. 워드프레스 4.9.4 버전(유지관리 릴리스)에서 이 버그가 수정되었습니다.

워드프레스가 4.9.3 버전으로 업데이트된 경우 4.9.4 버전은 자동으로 업데이트되지 않으니 수동으로 업데이트를 진행하시기 바랍니다.

참고로 어제 나왔던 4.9.3 버전에서는 사용자 정의하기 변경, 위젯, 비주얼 편집기, PHP 7.2 호환성 등 4.9 버전에서 발견된 34가지 버그가 수정되었다고 합니다. 그리고 이번 4.9.4 버전에서는 자동 업데이트가 실패하는 버그 하나가 수정되었습니다.

거듭 강조하는 내용이지만, 워드프레스 코어 파일, 테마 및 플러그인을 항상 최신 버전으로 업데이트하여 유지해야 보안상 좋습니다. 그리고 오랫동안 업데이트가 안 되고 방치되는 플러그인이나 테마는 사용하지 않는 것이 바람직합니다.

또한, 보안 플러그인을 설치하면 보안에 많은 도움이 됩니다.

마지막으로, 정기적으로 데이터와 DB를 백업을 해 놓으면 만약의 사태가 발생하더라도 사이트를 복구할 수 있습니다. 웹호스팅에서 자동 백업/복원을 지원하는 경우에도 별도의 백업본을 컴퓨터나 클라우드에 저장해놓는 것이 좋습니다.

*일부 글에 제휴링크가 포함될 수 있습니다.기부를 통해 블로그 운영을 후원하실 수 있습니다.

Related Posts

댓글 2건
  1. 이카루스

    저는 요 근래에 잠시 바빠서 4.9.3 업데이트가 되었다는 메세지만 보았는데 이런 긴급한 것이 있었네요..
    그래서 방금 로그인을 하니 4.9.4로 업데이트 하라는 문구가 나오더군요..
    잠시 망설이다가 했는데 다행히 이상은 없는 것 같아요..
    감사합니다..!!

    1. Word

      예전에는 워드프레스를 업데이트하거나 테마를 업데이트하면 사이트에 오류가 발생하는 경우가 간혹 있었지만 요즘은 그런 경우가 드문 것 같습니다.

댓글 남기기