워드프레스 Beaver Builder 플러그인과 구텐베르크 호환성

0

워드프레스 Beaver Builder 페이지 빌더

워드프레스에서 많이 사용되는 페이지 빌더로 Visual Composer가 있습니다. 하지만 비주얼 컴포저는 전문가들 사이에서 그리 좋은 평을 받지 못하고 있습니다. 괜찮은 평을 받고 있는 페이지 빌더로 Beaver Builder가 있습니다.

Beaver Builder는 무료 버전도 제공되므로 다운로드하여 사용해볼 수 있습니다. 유료 버전을 이용하면 프리미엄 모듈과 템플릿을 사용할 수 있습니다.

플러그인 개발자에게 Beaver Builder가 구텐베르크와 호환되는지 여부를 문의해보니 구텐베르크 및 워드프레스 5.0과 호환이 된다는 답변을 받았습니다.

Beaver Builder is compatible with WordPress 5.0 and Gutenberg.

Beaver Builder 문서를 확인해보니 Beaver Builder 플러그인 버전 2.1 이상이 구텐베르크와 호환된다고 하네요. 하지만 구텐베르크가 아직 안정화 단계가 아니고 릴리즈가 나올 때마다 변경되고 있으므로, 추후에 호환성 문제가 발생할 수 있습니다. 그런 경우 플러그인 개발자가 호환성 문제를 해결하도록 플러그인을 업데이트할 것입니다.

워드프레스 5에서 Beaver Builder와 구텐베르크 콘텐츠 간 변환이 가능합니다.

  1. 표준 편집기(Gutenberg) 콘텐츠를 Beaver Builder로 변환
  2. Classic Editor(고전 편집기) 콘텐츠를 Beaver Builder로 변환
  3. Beaver Builder 콘텐츠를 표준 편집기(Gutenberg)로 변환
  4. Beaver Builder 콘텐츠를 Classic Editor(고전 편집기)로 변환

예: Beaver 빌더 콘텐츠를 구텐베르크 블록으로 변환하기

워드프레스 Beaver Builder

예: 구텐베르크 콘텐츠를 Beaver Builder로 변환하기

워드프레스 Beaver Builder

Beaver Builder가 구텐베르크에 적극적으로 대응하여 한 발 앞서 가는 것 같습니다.

앞에서 밝혔듯이 구텐베르크는 워드프레스 5.0에 통합되어 나왔지만 아직은 안정화가 되지 않았습니다. 업데이트가 되면서 구텐베르크가 변경되어 호환성 문제가 발생할 수 있습니다. 12월은 많은 나라에서 연휴 기간이기 때문에 내년 1월이 되면 워드프레스 버그가 수정된 패치가 나올 예정이라고 합니다. 새로운 패치가 나오면 구텐베르크 버그가 어느 정도 잡히지 않을까 생각됩니다.

저는 모든 사이트를 워드프레스 5로 업데이트하고 당분간 구텐베르크 대신 고전 편집기를 기본 편집기로 설정하여 사용하고 있습니다. 워드프레스 5로 업데이트한 후에 문제가 발생할 경우 1) 구텐베르크를 비활성화할거나 2) 워드프레스를 이전 버전으로 다운그레이드할 수 있습니다.

Divi Builder 페이지 빌더를 사용하는 Divi 테마는 워드프레스 5.0이 릴리즈된 후에 1~2일마다 마이너 업데이트되고 있네요. Divi 테마는 버그가 발견되는 즉시 수정하여 새로운 업데이트를 내놓고 있는 것 같습니다.

참고:

※일부 글에 제휴링크가 포함될 수 있습니다._커피 한잔 값으로 블로그 운영을 후원하실 수 있습니다.