워드프레스 5.0으로 업데이트해도 될까?

0

워드프레스 5.0이 12월 6일(우리나라 시각으로 12월 7일경)에 공식 릴리즈될 예정입니다. 이제 이틀 후면 새로운 비주얼 편집기가 통합된 새로운 워드프레스를 만날 수 있습니다.

워드프레스 5.0

그 동안 말도 많고 논란이 많았던 구텐베르크가 워드프레스 5.0에서는 코어에 통합되어 기본 편집기로 사용됩니다.

워드프레스 5.0이 릴리스되면 업데이트해도 될까요? 여기에 대해 워드프레스 SEO 플러그인을 만든 Yoast에서는 “Should you update to WordPress 5.0?“이라는 글을 통해 패치가 나오는 내년 1월까지 기다리라고 하네요.

If there is no compelling reason for you to update, our suggestion is going to be: wait. WordPress 5.0 will probably be more stable in January than it is now.

꼭 업데이트를 해야 하는 이유가 없다면 기다리는 것이 좋습니다. 워드프레스 5.0은 1월이 되면 지금보다 더 안정적이 될 것입니다.

워드프레스 5.0으로 업데이트를 하려는 경우

워드프레스 5.0이 릴리즈될 때 곧바로 업그레이드를 하려는 경우 항상 그렇듯이 ‘백업’을 하시기 바랍니다. ‘스테이징’ 환경을 이용할 수 있다면 활용하는 것이 좋습니다.

메이저 업데이트를 실시할 때에는 항상 ‘백업’을 받아놓으시기 바랍니다.

구텐베르크는 글 작성 시 사용자 경험을 획기적으로 향상시키지만, 일부 플러그인에서는 제대로 작동하지 않을 수 있습니다. 사용 중인 플러그인이 구텐베르크와 호환되는지 여부를 체크한 후에 업데이트하는 것이 좋습니다.

워드프레스 5.0으로 업데이트를 하더라도 구텐베르크를 사용하지 않을 경우에는 Classic Editor 플러그인을 미리 설치하여 활성화한 후에 5.0으로 업데이트하시기 바랍니다.

5.0 이전 버전에서도 Gutenberg 플러그인을 설치하여 테스트해볼 수 있습니다. 하지만 여전히 사용자들의 평가는 박한 편입니다.

구텐베르크 플러그인에 대한 사용자들의 평가. 여전히 부정적인 평가가 대부분이다.

마치며

워드프레스 5.0이 릴리즈되면 곧바로 업그레이드할 지를 결정해야 합니다. 지금 바쁘거나 휴가 중이라면 2019년 1월에 버그가 수정된 패치 릴리즈가 예정되어 있으므로 1월까지 기다리는 것이 좋습니다.

구텐베르크 편집기를 사용하면 일반 글(포스트)에서도 페이지 빌더를 사용하지 않고 정교하게 글을 작성할 수 있습니다. 글을 작성할 때 고급 기능이 필요하지 않다면 ‘고전 편집기’ 플러그인을 설치하여 구텐베르크를 비활성화하는 것도 고려해볼 수 있습니다.

뮬런버그(Matt Mullenweg)가 야심 차게 밀어붙이고 있는 구텐베르크 프로젝트가 과연 기대했던 성과를 거둘 수 있을까요? 흥미를 가지고 지켜볼 부분 같습니다.

참고:

*일부 글에 제휴링크가 포함될 수 있습니다.기부를 통해 블로그 운영을 후원하실 수 있습니다.

Related Posts

댓글 남기기