워드프레스 보안 – 스팸 링크 인젝션 해킹 공격

3

워드프레스 보안

워드프레스 보안: 스팸 링크 인젝션 해킹 공격

워드프레스를 업데이트하지 않고 방치할 경우 다양한 보안 위협에 노출될 수 있습니다. 이 sucuri 글을 보면 최근 워드프레스를 최신 버전으로 업데이트하지 않을 경우 Content Injection Vulnerability(컨텐츠 인젝션 취약점)에 노출될 수 있음을 경고하고 있습니다.

링크된 글은 4.7.0이나 4.7.1에 발생하는 보안 위협에 대해 설명하고 있습니다. 참고로 이 글을 작성할 시점의 최신 버전은 4.7.3입니다. 워드프레스를 항상 최신 버전으로 유지하도록 합니다.

스팸 링크 인젝션 해킹을 당하면 사이트 컨텐츠에 SEO 스팸 캠페인(SEO spam campaign)이나 광고 링크가 삽입될 수 있습니다. 그렇게 되면 사이트 방문자들에게 이상한 광고가 표시되거나 팝업 광고가 표시될 수 있습니다. 사용자들은 이러한 사이트에 다시 방문하지 않으려고 할 수 있고 회사 사이트인 경우 회사의 이미지에 손상이 갈 수 있습니다.

(참고로 이 사이트에는 구글 애드센스 광고가 표시됩니다. 이상한 광고가 아니니 안심하셔도 됩니다.ㅎㅎ 다른 많은 블로그와 마찬가지로 이 블로그도 웹호스팅 비용 등을 구글 애드센스 광고 수익으로 일부 충당되고 있습니다. 애드블록 등 광고 차단 프로그램을 설치한 경우 이 사이트를 허용 목록(Whitelist)에 등록시켜주시면 정말 감사하겠습니다.)

문제는 이런 공격을 당해도 공격을 당한 후에는 보안 플러그인에서 제대로 감지하지 못하는 것 같습니다. 이런 공격을 당하기 전에 워드프레스 코어 파일, 플러그인, 테마를 최신 버전으로 유지하고 보안 플러그인을 설치하는 것이 중요합니다.

그리고 Exploit Scanner와 같은 플러그인을 사용하여 웹사이트 내의 파일, DB의 글 및 댓글 테이블에 의심스러운 것이 있는지 검색할 수 있습니다. 이 플러그인은 또한 활성화된 플러그인의 목록을 검사하여 비정상적인 파일이름이 있는지도 체크합니다.

Exploit Scanner를 이용해보니 잘 작동하지 않는 경우도 있었습니다. 이런 경우 Anti-Malware Security and Brute-Force Firewall(안티멀웨어 보안 및 무작위 대입 공격 방화벽)이라는 플러그인을 이용해볼 수 있습니다.

해킹을 당하거나 멀웨어에 감염되거나 하여 사이트의 파일에 변경이 있을 경우 이 플러그인이 유용할 것 같습니다. 하지만 일부 사이트에서는 제대로 작동하지 않는 문제가 있는 것으로 보입니다.

스팸 인젝션 공격을 당했을 경우 다음 사이트의 글을 참고로 적절한 조치를 취해보시기 바랍니다.

위에서도 밝혔듯이 스팸 인젝션 해킹은 감지가 쉽지 않기 때문에 미리 예방하는 것이 최선 같습니다. 그리고 구글의 “세이프 브라우징 사이트 상태” 사이트에서 구글이 내 사이트를 어떻게 보고 있는지 확인할 수 있습니다.

2017_1215_추가: 경험상 이런 멀웨어에 감염되면 데이터뿐만 아니라 DB에도 악성코드가 심어져 있을 수 있습니다. DB에 악성코드가 심어져 있는 경우에는 찾기가 쉽지 않고 해결하는 데 시간과 비용이 많이 들 수 있습니다.

해결하는 데 어려움을 겪는 경우 서비스(유료)를 의뢰할 수 있습니다. 또는, 보안업체인 Sucuri 사이트에서 라이브 채팅(오른쪽 하단에 위치)을 통해 상담을 받아볼 수도 있을 것 같습니다.

참고:

*일부 글에 제휴링크가 포함될 수 있으며, 기부를 통해 블로그 운영을 후원하실 수 있습니다.

Related Posts

3개 댓글
  1. Chris Mok 님의 말씀

    좋은 정보 감사합니다 ^^

    1. Word 님의 말씀

      댓글 감사합니다^^

      멀웨어에 감염되거나 해킹 당한 사이트 문제를 종종 접하는데요, 항상 조심해야겠다는 생각이 드네요. 백업도 철저히 하고요.ㅎㅎ

      1. Chris Mok 님의 말씀

        맞습니다. 워드프레스 사이트 고객꺼 200개 좀 넘게 Dedicated server 에 올려서 관리하고 있는데 자동 업데이트 플러그인 없었으면 정말 눈앞이 캄캄하네요

댓글 남기기