우커머스 3.5.4 이하 버전에 XSS(크로스 사이트 스크립팅) 보안 취약점 발견

0

최근 우커머스에서 XSS(크로스 사이트 스크립팅) 보안 취약점이 발견되었습니다. 이 취약점은 3.5.4 이하 버전에 존재하므로 우커머스를 반드시 최신 버전으로 업데이트하시기 바랍니다.

우커머스는 워드프레스에 사용되는 오픈 소스 전자상거래(eCommerce) 플랫입니다. Builtwith 통계에 의하면 우커머스는 가장 많이 사용되는 이커머스 플랫폼으로 2018년 전세계 시장 점유율 22%를 기록했습니다.

전세계 이커머스 시장 점유율
전세계 이커머스 시장 점유율. 출처: Builtwith

우커머스 3.5.4 이하 버전에서 발견된 XSS 취약점(CVE-2019-9168)은 Photoswipe 함수의 zoom display에 존재하는 것이라고 하네요. 전문적인 내용이라서 자세히 살펴보지는 않았습니다. 자세한 기술적인 내용이 궁금한 분은 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2019-9168 페이지를 참고해보시기 바랍니다.

워드프레스 자체는 보안에 강하지만 워드프레스 코어, 테마, 플러그인을 업데이트하지 않거나, 잘못된 보안 관행(예: 약한 비밀번호 사용)으로 인해 보안이 취약해질 수 있습니다.

항상 사이트를 최신 버전으로 유지하고 정기적으로 백업하여 PC나 클라우드 스토리지에 저장할 것을 권장합니다. 그리고 오랫동안 업데이트가 안 되고 버려진 플러그인도 가급적 사용하지 않는 것이 좋습니다.

특히 인기 있는 플러그인이나 테마에서 보안 취약점이 발견될 경우 악의적인 해커들은 플러그인이나 테마를 업데이트하지 않는 사이트를 노리는 멀웨어를 만들어 배포할 수 있습니다. 최근 악성코드 감염으로 문의해오시는 분들이 평소보다 많은 편입니다.

유비무환(有備無患). 미리 대비하는 것이 최선의 방책 같습니다. 사이트를 항상 최신 버전으로 업데이트하여 안전하게 홈페이지를 운영하시기 바랍니다.

참고:

※일부 글에 제휴링크가 포함될 수 있습니다._커피 한잔 값으로 블로그 운영을 후원하실 수 있습니다.