Browser

워드프레스 익스플로러 호환

워드프레스 사이트가 Internet Explorer에서 정상적으로 표시되지 않으면 다음 코드를 header.php의 head 부분 맨 위에 추가하도록 합니다.

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

그런데 다음과 같이 chrome=1을 추가해주면 ChromeFrame에는 전혀 영향을 미치지 않는다고 합니다(여기 참고).

<meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />

그리고 다음 코드를 사용하면 Internet Explorer HTML5 호환성 문제가 어느 정도 해결된다고 합니다(여기 참고).

<!--[if lt IE 9]>
<script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script>
<![endif]-->

참고: Visual Composer와 같은 페이지 빌더가 설치되어 있는 경우 비활성화하면 하위 Internet Explorer 버전에서 제대로 작동할 수 있습니다. 구형 IE 버전을 꼭 지원해야 하는 경우에는 테마를 구입하기 전에 반드시 하위 IE 버전과의 호환성을 확인하시기 바랍니다. 요즘 출시되는 테마는 IE 8 등 구형 IE를 지원하는 경우가 매우 드뭅니다.

떠나시기 전에 아무 댓글(Comments)이라도 남겨두세요.
기부를 통해 이 블로그의 운영을 후원하실 수 있습니다.