• 글쓴이
  • #8155

    wordcracker
    Keymaster

    WordPress를 설치하는 과정에서 다음과 같은 오류가 발생하는 경우:

    Download failed. error:0D0890A1:asn1 encoding routines:func(137):reason(161)

    이 오류는 서버에 구식 버전의 curl 또는 OpenSSL 라이브러리가 있는 경우에 발생한다고 하네요. Modern SSL 인증서는 SHA-256 알고리듬을 사용하여 Sign되지만 구식 코드에서는 이에 대한 지원이 부족하다고 합니다. 결국 서버를 업데이트해야 근본적으로 해결이 가능합니다.

    이에 대한 문제가 WordPress.org의 Support 페이지에 나와 있습니다. 이 페이지에 함수가 하나 나오는데요. 다음과 같은 함수입니다.

    function ssv_skip_ssl_verify($ssl_verify) {
        return false;
    }
    add_filter('https_ssl_verify', 'ssv_skip_ssl_verify');
    add_filter('https_local_ssl_verify', 'ssv_skip_ssl_verify');

    이 함수를 적용해보면 일시적으로 해결될 수 있지만 위험할 수 있다고 하네요.

답변은 로그인 후 가능합니다.