• 글쓴이
  • #12451

    wordcracker
    Keymaster

    IIS 8에 워드프레스를 설치하여 운영하는 경우 URL(고유주소)에 index.php가 붙는 경우가 있습니다. 예를 들어, http://www.abc.com/blog가 되어야 하지만 http://www.abc.com/index.php/blog처럼 표시될 수 있습니다. 이런 경우 web.config를 다음과 같이 변경하면 문제가 해결될 것입니다.

    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
        <system.webServer>
            <defaultDocument enabled="true">
                <files>
                    <add value="index.php" />
                </files>
            </defaultDocument>
            <rewrite>
                <rules>
                    <rule name="WPurls" enabled="true" stopProcessing="true">
                        <match url=".*" />
                        <conditions logicalGrouping="MatchAll">
                            <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />
                            <add input="{REQUEST_FILENAME}" matchType="IsDirectory" negate="true" />
                        </conditions>
                        <action type="Rewrite" url="index.php/{R:0}" />
                    </rule>
                </rules>
            </rewrite>
        </system.webServer>
    </configuration>
    
    

    직접 수정할 수 없다면 서버 관리자에게 index.php가 붙는다고 이야기해주면 조치를 취해줄 것입니다.

    IIS 7의 경우 이 글을 참고해보시기 바랍니다.

답변은 로그인 후 가능합니다.